<!DOCTYPE html>
<html class="root root_js_disabled" lang="en-US" data-version="2.5.5.1" data-platform="desktop">
<head>
    <meta charset="utf-8" />
    <title>Former state senator from Dallas will challenge Gov. Abbott | kiiitv.com</title>
    <script>!function(){window.performance.mark("tegna_server_response");let e=new URLSearchParams(window.location.search).get("otConsentString");if(e){document.cookie=`OptanonAlertBoxClosed=${(new Date).toISOString()}`;let n=new Date;n.setYear(n.getFullYear()+1),n=n.toISOString();let t=(new Date).toString().replace(/\ /g,"+").replace(/:/g,"%3A");document.cookie=`OptanonConsent=datestamp=${t}&version=6.0.0&interactionCount=0&isIABGlobal=false&landingPath=NotLandingPage&groups=${encodeURIComponent(e)}&hosts=&legInt=; expires=${n}`}}(),function(){window.tegna=window.tegna||{},window.tegna.supportsJavascript="noModule"in document.createElement("script"),window.tegna.supportsJavascript?(document.documentElement.classList.remove("root_js_disabled"),window.tegna.performance={received:{time:window.performance.now()}},window.tegna.ie=!!window.MSInputMethodContext&&!!document.documentMode):document.documentElement.classList.add("root_ie_true")}();
//# sourceMappingURL=immediate.js.map</script>
    <style>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</style>
    <style>:root {
    --theme-primary: #045ea8;
    --theme-secondary: #045ea8;
}</style>

<link rel="preload" href="/modules.min_5.5.1.css" as="style" onload="this.onload=null;this.rel='stylesheet';window.tegna.performance.painted = { 'time': window.performance.now() };window.performance.mark('tegna_styled');" />
<noscript><link rel="stylesheet" href="/modules.min_5.5.1.css"></noscript>

<link rel="preload" href="/common.min_5.5.1.js?ver=5.5.1" as="script" type="text/javascript" />

    <link rel="preconnect" href="//media.wbir.com">
    <link rel="preconnect" href="//interactive.wbir.com">
    <link rel="preconnect" href="//tgna-ux-dev.service.signalr.net">
    <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    <link rel="preconnect" href="//www.google.com">
    <link rel="preconnect" href="//adservice.google.com">
    <link rel="preconnect" href="//tpc.googlesyndication.com">
    <link rel="preconnect" href="//cdn.ampproject.org">
    <link rel="preconnect" href="//pagead2.googlesyndication.com">
    <link rel="preconnect" href="//www.gstatic.com">
    <link rel="icon" href="/assets/favicons/KIII.png?ver=2.5.5.1" />
    <link rel="canonical" href="https://www.wfaa.com/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c" />
        <link rel="alternate" href="https://www.kiiitv.com/mobile/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c" />
                    <link rel="amphtml" href="https://www.kiiitv.com/amp/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c" />
        <meta itemprop="datePublished" content="10:11 AM CDT May 10, 2021" />
        <meta itemprop="dateModified" content="10:11 AM CDT May 10, 2021" />
        <meta itemprop="url" content="https://www.kiiitv.com/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c" />
        <meta itemprop="magnet:custom" name="category" content="news" />
        <meta property="og:url" content="https://www.kiiitv.com/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c">
        <meta property="og:title" content="Republican former state Sen. Don Huffines launches primary challenge to Gov. Greg Abbott">
        <meta property="og:description" content="Huffines, who has criticized Abbott as being too slow to fully reopen the state, served in the Senate from 2015-2019.">
        <meta property="og:type" content="article" />
        <meta property="og:image" content="https://media.kiiitv.com/assets/WFAA/images/d10a1b51-218b-42e1-9051-66e2cfb27c3c/d10a1b51-218b-42e1-9051-66e2cfb27c3c_1140x641.jpg">
        <meta property="og:image:width" content="1140" />
        <meta property="og:image:height" content="641" />
        <meta property="og:article:published_time" content="10:11 AM CDT May 10, 2021" />
        <meta property="article:opinion" content="false" />
        <meta property="article:content_tier" content="free">
        <meta name="twitter:title" content="Republican former state Sen. Don Huffines launches primary challenge to Gov. Greg Abbott">
        <meta name="twitter:image:src" content="https://media.kiiitv.com/assets/WFAA/images/d10a1b51-218b-42e1-9051-66e2cfb27c3c/d10a1b51-218b-42e1-9051-66e2cfb27c3c_1140x641.jpg">
        <meta name="twitter:image" content="https://media.kiiitv.com/assets/WFAA/images/d10a1b51-218b-42e1-9051-66e2cfb27c3c/d10a1b51-218b-42e1-9051-66e2cfb27c3c_1140x641.jpg">
        <meta name="twitter:card" content="summary_large_image">
        <meta name="twitter:site" content="kiii3news">
        <meta name="twitter:description" content="Huffines, who has criticized Abbott as being too slow to fully reopen the state, served in the Senate from 2015-2019.">
        <meta name="twitter:domain" content="www.kiiitv.com">
    

            <meta name="viewport" content="width=1170" />
            <meta name="site" content="kiiitv.com" />
            <meta name="description" content="Conservative Republican Don Huffines, who&#x27;s been critical of Gov. Greg Abbott&#x27;s coronavirus policies, announced Monday that he will challenge in the primary." />
            <meta property="fb:app_id" content="925032594320493" />
            <meta property="og:site_name" content="kiiitv.com" />
            <meta property="og:locale" content="en_US" />
            <meta itemprop="pageType" content="article" />
            <meta itemprop="datePublished" content="10:11 AM CDT May 10, 2021" />
    <script>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</script>
        <!-- OneTrust Cookies Consent Notice start -->
        <script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charset="UTF-8" data-domain-script="5de81b8c-51ec-4789-a501-f0ed8160ef0a"></script>
        <script type="text/javascript">function OptanonWrapper() { }</script>
        <!-- OneTrust Cookies Consent Notice end -->
        <script src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js" type="text/javascript" charset="UTF-8" ccpa-opt-out-ids="C0004,C0002" ccpa-opt-out-geo="all" ccpa-opt-out-lspa="true"></script>
            <script data-publisher-id="3276" data-timeout="1000">window.tegna.supportsJavascript&&(function(t,n,e,i,a,o,s){function c(e,i){n[t]._Q.push([e,i])}n[t]||(n[t]={init:function(){c("i",arguments)},fetchBids:function(){c("f",arguments)},setDisplayBids:function(){},_Q:[]},(o=e.createElement(i)).async=!0,o.src="//c.amazon-adsystem.com/aax2/apstag.js",(s=e.getElementsByTagName(i)[0]).parentNode.insertBefore(o,s))}("apstag",window,document,"script"),function(){window.tegna=window.tegna||{},window.tegna.getCookie=function(t,n){try{return document.cookie.split("; ").find(n=>n.startsWith(t)).split("=")[1]}catch(t){return n}};const t={pubID:document.currentScript.dataset.publisherId,adServer:"googletag",videoAdServer:"DFP",bidTimeout:document.currentScript.dataset.timeout,params:{us_privacy:window.tegna.getCookie("usprivacy","1---")}};void 0,window.apstag.init(t)}());
//# sourceMappingURL=amazona9.js.map</script>
            <script>if(window.tegna.supportsJavascript){var googletag=googletag||{};googletag.cmd=googletag.cmd||[],googletag.cmd.push(function(){googletag.pubads().enableSingleRequest(),googletag.pubads().disableInitialLoad();for(var e=0;e<document.getElementsByClassName("page")[0].attributes.length;e++){var t=document.getElementsByClassName("page")[0].attributes[e];if(t.nodeName.startsWith("data-targeting-")){let e,a=t.nodeName.replace("data-targeting-","");try{e=JSON.parse(t.nodeValue)}catch(a){e=t.nodeValue}!1===e&&(e="False"),!0===e&&(e="True"),googletag.pubads().setTargeting(a,e)}}googletag.enableServices()}),window.tegna=window.tegna||{},window.tegna.ads={_isNumeric:function(e){return"string"==typeof e&&(!isNaN(e)&&!isNaN(parseFloat(e)))},_slots:{},_onPubads:function(e,t){googletag.cmd.push(function(){googletag.pubads().addEventListener(e,function(e){t(e)})})},_request:function(e,t){googletag.cmd.push(function(){var a=document.getElementById(e),s=a.parentElement.dataset,g=s.path,o=JSON.parse(s.sizes),n=googletag.defineSlot(g,o,e).addService(googletag.pubads());a.dataset.status="requesting",window.tegna.ads._slots[e]={el:a,id:e,path:g,sizes:o,slot:n},window.tegna.ads.setTargetingFromDataset(e,n),googletag.display(e),a.dataset.status="requested",t(e)})},setTargetingFromDataset:function(e,t){var a=document.getElementById(e);if(window.PWT&&window.PWT.removeKeyValuePairsFromGPTSlots){[].push(t),window.PWT.removeKeyValuePairsFromGPTSlots(t)}for(var s=0;s<a.parentElement.attributes.length;s++){var g=a.parentElement.attributes[s];if(g.nodeName.startsWith("data-targeting-")){let e,a=g.nodeName.replace("data-targeting-","");if(window.tegna.ads._isNumeric(g.nodeValue))e=g.nodeValue;else try{e=JSON.parse(g.nodeValue)}catch(t){e=g.nodeValue}!1===e&&(e="False"),!0===e&&(e="True"),t.setTargeting(a,e)}}},refresh:function(e){e in window.tegna.ads._slots?(tegna.log("_gpt","displaying",e),document.getElementById(e).parentElement.dataset.status="rendering",window.tegna.ads.setTargetingFromDataset(e,window.tegna.ads._slots[e].slot),googletag.pubads().refresh([window.tegna.ads._slots[e].slot])):(tegna.log("_gpt","requesting",e),window.tegna.ads._request(e,this.refresh))}},window.tegna.ads._onPubads("slotRenderEnded",function(e){document.getElementById(e.slot.getSlotId().getDomId()).parentElement.dataset.status="rendered",document.getElementById(e.slot.getSlotId().getDomId()).style.opacity="1";var t,a={$el:$("#"+e.slot.getSlotElementId()),id:e.slot.getSlotId().getDomId(),request:{adUnitPath:e.slot.getSlotId().getAdUnitPath(),domId:e.slot.getSlotId().getDomId(),id:e.slot.getSlotId().getId(),name:e.slot.getSlotId().getName(),sizes:(t=[],$.each(e.slot.getSizes(),function(e,a){var s={},g=!1;$.each(a,function(e,t){"number"==typeof t&&(g?s.height=t:s.width=t,g=!0)}),t.push(s)}),t),targeting:e.slot.getTargeting(),outOfPage:e.slot.getOutOfPage()},response:{advertiser:e.advertiserId,creative:e.creativeId,creativeTemplate:e.creativeTemplateId,companies:e.companyIds,campaign:e.campaignId,labels:e.labelIds,yieldGroups:e.yieldGroupIds,isBackfill:e.isBackfill,isEmpty:e.isEmpty,sourceAgnosticCreative:e.sourceAgnosticCreativeId,sourceAgnosticLineItem:e.sourceAgnosticLineItemId,size:{width:e.size&&e.size.length>0?e.size[0]:0,height:e.size&&e.size.length>1?e.size[1]:0,toString:function(){return e.size&&e.size.length>1?e.size[0].toString()+"x"+e.size[1].toString():"0x0"}},service:e.serviceName,html:e.slot.getHtml(),isOutOfPage:e.slot.getOutOfPage(),targeting:{map:e.slot.getTargetingMap(),keys:e.slot.getTargetingKeys(),list:e.slot.getTargeting()},clickUrl:e.slot.getClickUrl()}};"$"in window&&$(window).trigger("tegnaBroadcast",["_gpt","slotRenderEnded",a]),tegna.log("_gpt","slotRenderEnded",a)})}
//# sourceMappingURL=gpt.js.map</script>
<!-- utag_data -->
<script id="utag_data_script" data-page-type="article" data-gpt-network-code="32805352/tx-corpuschristi-KIII-B3364_DesktopTablet" data-section="news" data-subsection="politics" data-topic="None" data-subtopic="" data-content-type="article" data-category="news" data-market="Corpus Christi, TX" data-subcategory="politics" data-keywords="KIII, Corpus Christi, TX, news, local news, breaking news, traffic, weather, sports, events,KIII" data-document-title="Corpus Christi&#x27;s Leading Local News: Weather, Traffic, Sports and more | Corpus Christi, Texas | kiiitv.com" data-ga-property-id="UA-80328443-1" data-division="broadcast" data-site-type="desktop" data-page-url="https://www.kiiitv.com/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c" data-canonical-url="https://www.wfaa.com/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c" data-asset-id="3ec6c658-1b45-4bfa-875b-c78ff659ae8c" data-article-keywords="politics,news,home" data-content-title="Republican former state Sen. Don Huffines launches primary challenge to Gov. Greg Abbott" data-content-categories="politics,news,home" data-content-score="85" data-tracking-tags="" data-t1-publisher="Elizabeth Wiley" data-call-letters="KIII" data-article-byline="Patrick Svitek (The Texas Tribune)" data-topics-included="false" data-video-included="true" data-video-autoplay="true" data-video-title="Republican former state Sen. Don Huffines launches primary challenge to Gov. Greg Abbott" data-item-number="1" data-original-headline="Republican former state Sen. Don Huffines launches primary challenge to Gov. Greg Abbott" data-cct-story="false" data-platform="desktop">!function(){if(window.tegna.supportsJavascript){var t=document.getElementById("utag_data_script").dataset;window.utag_data={template_type:"",page_type:t.pageType,division:t.division,site_type:t.siteType,page_url:t.pageUrl,gpt_network_code:t.gptNetworkCode,section:t.section,subsection:t.subsection,topic:t.topic,subtopic:t.subtopic,content_type:t.contentType,category:t.category,market:t.market,subcategory:t.subcategory,keywords:t.keywords,document_title:t.documentTitle,ga_property_id:t.gaPropertyId,canonical_url:t.canonicalUrl,video_included:t.videoIncluded,article_date:t.articleDate,asset_id:t.assetId,article_keywords:t.articleKeywords,content_title:t.contentTitle,original_headline:t.originalHeadline,content_categories:t.contentCategories,tracking_tags:t.trackingTags,t1_publisher:t.t1Publisher,article_byline:t.articleByline,topics_included:t.topicsIncluded,call_letters:t.callLetters,item_number:t.itemNumber,content_score:t.contentScore,cct_story:t.cctStory,platform:t.platform}}}();
//# sourceMappingURL=utag-data.js.map</script>            <script src="https://www.google.com/recaptcha/api.js?onload=recaptchaCallback&render=explicit" async defer></script>
        <script type="text/javascript">
            var recaptchaCallback = function () {
                window.grecaptcha = grecaptcha;
                console.log('recaptcha is ready');
            }
        </script>
    <style>
        .root_ie_true template {
            display: none;
        }
        #onetrust-consent-sdk #onetrust-pc-sdk .pc-header {
            position: relative;
        }
        #onetrust-consent-sdk #onetrust-pc-sdk .pc-logo {
            background-image: url('/assets/shared-images/logos/kiii.png') !important;
        }
    </style>
        <script type="text/javascript" data-taboola-type="article">
            window._taboola = window._taboola || [];
            let obj = {};
            obj[document.currentScript.dataset.taboolaType] = 'auto';
            _taboola.push(obj);
        </script>
    <!-- head content below this is dynamically added -->
</head>
<body>
    <script>if(window.tegna.supportsJavascript){window.tegna.log=function(t,e,i,n){var o=20-t.length;o=o<0?0:o;var r=30-e.length;r=r<0?0:r;var a="log";"error"in console&&3===n?a="error":"warn"in console&&2===n?a="warn":"info"in console&&(a="info");var s="["+t+"] "+" ".repeat(o)+e+" ".repeat(r);i?void 0:void 0},window.tegna.loadModule=function(t,e){var i=t.parentNode,n=i.querySelectorAll(".grid__template")[0];"undefined"!=typeof templatePolyfill&&templatePolyfill(i);var o=document.importNode(n.content,!0),r="IntersectionObserver"in window&&"IntersectionObserverEntry"in window;t.remove(),r?new window.IntersectionObserver(function(t,r){t.forEach(function(t){if(t.isIntersecting){n.remove(),i.append(o),i.closest(".grid__module").classList.add("grid__module_loaded_true"),i.closest(".grid__module").classList.remove("grid__module_loaded_false"),r.unobserve(i),"undefined"!=typeof require&&require([e]),"$"in window&&$(window).trigger("tegnaBroadcast",["grid","addedSection",{$el:$(i)}]);let t={el:i};"$"in window&&(t.$el=$(i)),window.dispatchEvent(new CustomEvent("tegnaBroadcastNoJQ",{detail:{source:"grid",action:"addedSection",data:t}}))}})}).observe(i):(n.remove(),i.append(o))};class t extends HTMLElement{get os(){return this.getAttribute("os")}set os(t){this.setAttribute("os",t)}set active(t){t?(this.setAttribute("aria-hidden","false"),this.setAttribute("active","")):(this.setAttribute("aria-hidden","true"),this.removeAttribute("active"))}constructor(){super()}connectedCallback(){const t=navigator.userAgent||navigator.vendor||window.opera;let e="unknown";/android/i.test(t)&&(e="android"),/iPad|iPhone|iPod/.test(t)&&!window.MSStream&&(e="ios"),e===this.os.toLowerCase()?this.active=!0:this.active=!1}}window.customElements.define("tegna-sniff",t);class e extends HTMLElement{get uuid(){return this.getAttribute("uuid")}set uuid(t){this.setAttribute("uuid",t)}set active(t){t?(this.setAttribute("aria-hidden","false"),this.setAttribute("active","")):(this.setAttribute("aria-hidden","true"),this.removeAttribute("active"))}constructor(){super()}}window.customElements.define("tegna-variant",e);class i extends HTMLElement{get uuid(){return this.getAttribute("uuid")}set uuid(t){this.setAttribute("uuid",t)}constructor(){super()}connectedCallback(){var t;window.setTimeout(()=>{let e=[...this.children],i=e[0].uuid,n=window.localStorage.getItem(this.uuid);null!==n?(i=n,window.tegna.log("_abtest","showingStoredVariant",{test:this.uuid,variant:n})):(i=e[(t=e.length,Math.floor(Math.random()*Math.floor(t)))].uuid,window.localStorage.setItem(this.uuid,i),window.localStorage.setItem(`${this.uuid}_tegna_expire`,Date.now()+108e5),window.tegna.log("_abtest","showingNewVariant",{test:this.uuid,variant:i}));const o=async(t,e,n)=>{const o=document.querySelector(".page").dataset.uxTrackingUrl;(await fetch(o,{method:"POST",headers:{"Content-Type":"application/json",pragma:"no-cache","cache-control":"no-cache"},body:JSON.stringify({testId:this.uuid,siteId:document.querySelector(".page").dataset.siteId,variantId:i,click:t?1:0,impression:e?1:0})})).text().then(t=>{n(t)})};for(var r=0;r<e.length;r++)if(e[r].uuid===i){e[r].active=!0,[...e[r].querySelectorAll("a:not([data-ab-click-mode=ignore])")].forEach((t,e)=>{t.addEventListener("click",e=>{e.preventDefault(),e.stopPropagation(),o(!0,!1,()=>{window.location=t.getAttribute("href")}),window.setTimeout(()=>{window.location=t.getAttribute("href")},500)})}),new IntersectionObserver((t,e)=>{t.forEach(t=>{t.isIntersecting?(window.tegna.log("_abtest","attemptingImpression",{el:this,test:this.uuid,variant:i}),o(!1,!0,()=>{window.tegna.log("_abtest","impression",{el:this,test:this.uuid,variant:i})}),e.unobserve(t.target)):window.tegna.log("_abtest","notIntersecting")})}).observe(this)}else e[r].active=!1})}}window.customElements.define("tegna-ab",i)}
//# sourceMappingURL=above-page-scripts.js.map</script>
    <div data-module="page" data-state="ready" class="page"
         data-embed="false"
         data-platform="desktop"
         data-ux-tracking-url="https://abtesting.tegnadigital.com/api/SendUxAbTestingData?code=IauHSBWa4wWptdFrRCmQBeReTLeZXdGAaoRuXkn6jy8AVdi7g0Bwlg=="
         data-api-key=""
         data-environment="Production"
         data-is-monitor="false"
         data-is-preview="false"
         data-site-id="503"
         data-primarydomain="kiiitv.com"
         data-call-letters="KIII"
         data-twitter-id="kiii3news"
         data-fban="925032594320493"
         data-refresh="420"
         data-dfpid="32805352"
         data-comscoreid="19962895"
         data-recaptchasitekey="6LdhZY8UAAAAANQxx8Y6_JJZSJtONlMiM_yiKTah"
         data-targeting-video_included="true"
         data-targeting-ttid="3ec6c658-1b45-4bfa-875b-c78ff659ae8c"
         data-targeting-pgtype="article"
         data-targeting-topic_section=""
         data-targeting-url="https://www.kiiitv.com/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c"
         data-is-video="false"
         data-is-longform="false"
         data-gptid="tx-corpuschristi-KIII-B3364_DesktopTablet"
         data-tealium-url="//tags.tiqcdn.com/utag/tegna/kiii-redesign-desktop/prod/utag"
         data-pubmatic-enabled="true"
         data-pubmatic-desktop-url="https://ads.pubmatic.com/AdServer/js/pwt/160138/3944/pwt.js"
         data-pubmatic-mobile-url="https://ads.pubmatic.com/AdServer/js/pwt/160138/3945/pwt.js"
         data-tealium-id-chartbeat="2"data-tealium-id-comscore="1"data-tealium-id-datasphere="000"data-tealium-id-dealboss="000"data-tealium-id-googleanalytics="472"data-tealium-id-simplifi="521"data-tealium-id-taboola="520"data-tealium-id-truanthem="442"data-tealium-id-visto="464"         >
            <div class="page__top">

    <div class="universal-ad" data-module="universal-ad">
        <div class="universal-ad__close-button">
            <img src="/assets/shared-images/icons/close-menu.svg" alt="x" width="14" height="14" />
        </div>
        <div class="universal-ad__ad">
        <div data-module="ad" class="ad ad_position_article_universal ad_background_true"
         data-status="new"
         data-path="/32805352/tx-corpuschristi-KIII-B3364_DesktopTablet/article_universal/news/politics"
         data-sizes="[[1140,250],[970,250],[728,90],[1,1]]"
         data-delay="0"
         data-position="article_universal"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-a9-enabled="true"
         data-index-enabled="false"
         data-index-url="//js-sec.indexww.com/ht/p/184603-10280351191959.js"
         data-targeting-strnativekey=""
         data-collapse="false">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
        </div>
    </div>
            </div>
                    <div class="page__header">
<header data-module="header" class="header"
        data-alerts="false"
        data-facebook-app-id="925032594320493"
        data-twitter-id="kiii3news">
    <a class="header__skip" href="#main">Skip Navigation</a>
    <div class="header__main">
        <ul class="header__social-list">
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_facebook" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="facebook">Share on Facebook</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_twitter" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="twitter">Share on Twitter</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_sms" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="sms">Share on SMS</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_email" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="email">Share on Email</a>
            </li>
        </ul>
        <div class="header__main-inner">
            <div class="header__hamburger">
                <div class="header__hamburger-icon-container">
                    <div class="header__hamburger-icon"></div>
                </div>
            </div>
            <a class="header__station-branding" href="/" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="masthead-logo">
                <img class="header__logo" alt="Home" src="/assets/shared-images/logos/kiii.png" loading="eager" width="112" onload="this.parentElement.style.opacity='1';" />
            </a>
            <nav class="header__not-logo">
                <h2 class="header__nav-heading">Navigation</h2>
                <ul class="header__nav">
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_true" href="/news" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="News">
                                        <span class="header__nav-label">News</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/local" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Local">
                                                                    <span class="header__subnav-label">Local</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/community" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Community">
                                                                    <span class="header__subnav-label">Community</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/texas-deep-dive" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Texas Deep Dive">
                                                                    <span class="header__subnav-label">Texas Deep Dive</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/nation-world" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Nation World">
                                                                    <span class="header__subnav-label">Nation World</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/money" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Money">
                                                                    <span class="header__subnav-label">Money</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/politics" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Politics">
                                                                    <span class="header__subnav-label">Politics</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/health" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Health">
                                                                    <span class="header__subnav-label">Health</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/entertainment" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Entertainment">
                                                                    <span class="header__subnav-label">Entertainment</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/contests" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Contests">
                                                                    <span class="header__subnav-label">Contests</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/features" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Features">
                                                                    <span class="header__subnav-label">Features</span>
                                                        </a>
                                                    </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest News Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/article/sports/high-school/hs-softball-playoffs-schedules-scores-and-highlights-kiii-3sports/503-e2701b49-d112-4d07-8f2f-f61f9b94c723" aria-label="Read H.S. Softball Playoffs - Schedules, Scores and Highlights">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="H.S. Softball Playoffs - Schedules, Scores and Highlights" width="" height="" src="https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="H.S. Softball Playoffs - Schedules, Scores and Highlights" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_360x203.jpg" data-srcset="https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_16x9.jpg 16w, https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_140x79.jpg 140w, https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_360x203.jpg 360w, https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_540x304.jpg 540w, https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_750x422.jpg 750w, https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_1140x641.jpg 1140w, https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/sports/high-school/hs-softball-playoffs-schedules-scores-and-highlights-kiii-3sports/503-e2701b49-d112-4d07-8f2f-f61f9b94c723">H.S. Softball Playoffs - Schedules, Scores and Highlights</a></h4>
                                            </div>
            </li>
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/article/sports/high-school/hs-baseball-playoffs-schedules-scores-and-highlights-kiii-3sports/503-6fffaf85-48bd-4428-b2ef-2c5c1889e030" aria-label="Read H.S. Baseball Playoffs - Schedules, Scores and Highlights">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="H.S. Baseball Playoffs - Schedules, Scores and Highlights" width="" height="" src="https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="H.S. Baseball Playoffs - Schedules, Scores and Highlights" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_360x203.jpg" data-srcset="https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_16x9.jpg 16w, https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_140x79.jpg 140w, https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_360x203.jpg 360w, https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_540x304.jpg 540w, https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_750x422.jpg 750w, https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_1140x641.jpg 1140w, https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/sports/high-school/hs-baseball-playoffs-schedules-scores-and-highlights-kiii-3sports/503-6fffaf85-48bd-4428-b2ef-2c5c1889e030">H.S. Baseball Playoffs - Schedules, Scores and Highlights</a></h4>
                                            </div>
            </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_true" href="/weather/" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Weather">
                                        <span class="header__nav-label">Weather</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/forecast" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Forecast">
                                                                    <span class="header__subnav-label">Forecast</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/radar" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Radar">
                                                                    <span class="header__subnav-label">Radar</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/10-day" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="10-Day">
                                                                    <span class="header__subnav-label">10-Day</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/hourly" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Hourly">
                                                                    <span class="header__subnav-label">Hourly</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/weather-maps" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Maps">
                                                                    <span class="header__subnav-label">Maps</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/hurricane-central" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Hurricane Central">
                                                                    <span class="header__subnav-label">Hurricane Central</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/traffic" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Traffic">
                                                                    <span class="header__subnav-label">Traffic</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/closings" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Closings &amp; Delays">
                                                                    <span class="header__subnav-label">Closings &amp; Delays</span>
                                                        </a>
                                                    </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest Weather Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/video/weather/accuweather/low-crop-counts-mean-increased-interest/607-eeb4fe10-f0a4-4659-ab6b-effbcc50c561" aria-label="Read Low crop counts mean increased interest">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="Low crop counts mean increased interest" width="" height="" src="https://media.kiiitv.com/assets/ACCUWEATHER/images/978b1503-dd41-4e31-ae9e-7b2376a61486/978b1503-dd41-4e31-ae9e-7b2376a61486_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="Low crop counts mean increased interest" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.kiiitv.com/assets/ACCUWEATHER/images/978b1503-dd41-4e31-ae9e-7b2376a61486/978b1503-dd41-4e31-ae9e-7b2376a61486_360x203.jpg" data-srcset="https://media.kiiitv.com/assets/ACCUWEATHER/images/978b1503-dd41-4e31-ae9e-7b2376a61486/978b1503-dd41-4e31-ae9e-7b2376a61486_16x9.jpg 16w, https://media.kiiitv.com/assets/ACCUWEATHER/images/978b1503-dd41-4e31-ae9e-7b2376a61486/978b1503-dd41-4e31-ae9e-7b2376a61486_140x79.jpg 140w, https://media.kiiitv.com/assets/ACCUWEATHER/images/978b1503-dd41-4e31-ae9e-7b2376a61486/978b1503-dd41-4e31-ae9e-7b2376a61486_360x203.jpg 360w, https://media.kiiitv.com/assets/ACCUWEATHER/images/978b1503-dd41-4e31-ae9e-7b2376a61486/978b1503-dd41-4e31-ae9e-7b2376a61486_540x304.jpg 540w, https://media.kiiitv.com/assets/ACCUWEATHER/images/978b1503-dd41-4e31-ae9e-7b2376a61486/978b1503-dd41-4e31-ae9e-7b2376a61486_750x422.jpg 750w, https://media.kiiitv.com/assets/ACCUWEATHER/images/978b1503-dd41-4e31-ae9e-7b2376a61486/978b1503-dd41-4e31-ae9e-7b2376a61486_1140x641.jpg 1140w, https://media.kiiitv.com/assets/ACCUWEATHER/images/978b1503-dd41-4e31-ae9e-7b2376a61486/978b1503-dd41-4e31-ae9e-7b2376a61486_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/video/weather/accuweather/low-crop-counts-mean-increased-interest/607-eeb4fe10-f0a4-4659-ab6b-effbcc50c561">Low crop counts mean increased interest</a></h4>
                                            </div>
            </li>
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/video/weather/accuweather/how-covid-19-has-increased-the-price-of-lumber/607-7dce0f46-f0a0-4d05-8d79-572c35b9caad" aria-label="Read How COVID-19 has increased the price of lumber">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="How COVID-19 has increased the price of lumber" width="" height="" src="https://media.kiiitv.com/assets/ACCUWEATHER/images/b9c810c8-a600-433e-b2aa-0ca6449607a7/b9c810c8-a600-433e-b2aa-0ca6449607a7_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="How COVID-19 has increased the price of lumber" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.kiiitv.com/assets/ACCUWEATHER/images/b9c810c8-a600-433e-b2aa-0ca6449607a7/b9c810c8-a600-433e-b2aa-0ca6449607a7_360x203.jpg" data-srcset="https://media.kiiitv.com/assets/ACCUWEATHER/images/b9c810c8-a600-433e-b2aa-0ca6449607a7/b9c810c8-a600-433e-b2aa-0ca6449607a7_16x9.jpg 16w, https://media.kiiitv.com/assets/ACCUWEATHER/images/b9c810c8-a600-433e-b2aa-0ca6449607a7/b9c810c8-a600-433e-b2aa-0ca6449607a7_140x79.jpg 140w, https://media.kiiitv.com/assets/ACCUWEATHER/images/b9c810c8-a600-433e-b2aa-0ca6449607a7/b9c810c8-a600-433e-b2aa-0ca6449607a7_360x203.jpg 360w, https://media.kiiitv.com/assets/ACCUWEATHER/images/b9c810c8-a600-433e-b2aa-0ca6449607a7/b9c810c8-a600-433e-b2aa-0ca6449607a7_540x304.jpg 540w, https://media.kiiitv.com/assets/ACCUWEATHER/images/b9c810c8-a600-433e-b2aa-0ca6449607a7/b9c810c8-a600-433e-b2aa-0ca6449607a7_750x422.jpg 750w, https://media.kiiitv.com/assets/ACCUWEATHER/images/b9c810c8-a600-433e-b2aa-0ca6449607a7/b9c810c8-a600-433e-b2aa-0ca6449607a7_1140x641.jpg 1140w, https://media.kiiitv.com/assets/ACCUWEATHER/images/b9c810c8-a600-433e-b2aa-0ca6449607a7/b9c810c8-a600-433e-b2aa-0ca6449607a7_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/video/weather/accuweather/how-covid-19-has-increased-the-price-of-lumber/607-7dce0f46-f0a0-4d05-8d79-572c35b9caad">How COVID-19 has increased the price of lumber</a></h4>
                                            </div>
            </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_true" href="/sports" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Sports">
                                        <span class="header__nav-label">Sports</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/hss" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="High School">
                                                                    <span class="header__subnav-label">High School</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/sports-blitz" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Friday Night Sports Blitz">
                                                                    <span class="header__subnav-label">Friday Night Sports Blitz</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/islanders" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Islanders">
                                                                    <span class="header__subnav-label">Islanders</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/javelinas" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Javelinas">
                                                                    <span class="header__subnav-label">Javelinas</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/hooks" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Hooks">
                                                                    <span class="header__subnav-label">Hooks</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/icerays" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="IceRays">
                                                                    <span class="header__subnav-label">IceRays</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/athlete-of-the-week" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Athlete of the Week">
                                                                    <span class="header__subnav-label">Athlete of the Week</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/blitz-band-of-the-week" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Blitz Band of the Week">
                                                                    <span class="header__subnav-label">Blitz Band of the Week</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/sportsmanship-awards" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Sportsmanship Awards">
                                                                    <span class="header__subnav-label">Sportsmanship Awards</span>
                                                        </a>
                                                    </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest Sports Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/article/sports/high-school/hs-baseball-playoffs-schedules-scores-and-highlights-kiii-3sports/503-6fffaf85-48bd-4428-b2ef-2c5c1889e030" aria-label="Read H.S. Baseball Playoffs - Schedules, Scores and Highlights">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="H.S. Baseball Playoffs - Schedules, Scores and Highlights" width="" height="" src="https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="H.S. Baseball Playoffs - Schedules, Scores and Highlights" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_360x203.jpg" data-srcset="https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_16x9.jpg 16w, https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_140x79.jpg 140w, https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_360x203.jpg 360w, https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_540x304.jpg 540w, https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_750x422.jpg 750w, https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_1140x641.jpg 1140w, https://media.kiiitv.com/assets/KIII/images/714d6102-c2e3-4b9f-9849-de98043ca471/714d6102-c2e3-4b9f-9849-de98043ca471_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/sports/high-school/hs-baseball-playoffs-schedules-scores-and-highlights-kiii-3sports/503-6fffaf85-48bd-4428-b2ef-2c5c1889e030">H.S. Baseball Playoffs - Schedules, Scores and Highlights</a></h4>
                                            </div>
            </li>
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/article/sports/high-school/hs-softball-playoffs-schedules-scores-and-highlights-kiii-3sports/503-e2701b49-d112-4d07-8f2f-f61f9b94c723" aria-label="Read H.S. Softball Playoffs - Schedules, Scores and Highlights">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="H.S. Softball Playoffs - Schedules, Scores and Highlights" width="" height="" src="https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="H.S. Softball Playoffs - Schedules, Scores and Highlights" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_360x203.jpg" data-srcset="https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_16x9.jpg 16w, https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_140x79.jpg 140w, https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_360x203.jpg 360w, https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_540x304.jpg 540w, https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_750x422.jpg 750w, https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_1140x641.jpg 1140w, https://media.kiiitv.com/assets/KIII/images/54e11b0d-c993-41c3-98b8-d042249a6b87/54e11b0d-c993-41c3-98b8-d042249a6b87_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/sports/high-school/hs-softball-playoffs-schedules-scores-and-highlights-kiii-3sports/503-e2701b49-d112-4d07-8f2f-f61f9b94c723">H.S. Softball Playoffs - Schedules, Scores and Highlights</a></h4>
                                            </div>
            </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_true" href="/connect" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Connect">
                                        <span class="header__nav-label">Connect</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/about-us" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="About Us">
                                                                    <span class="header__subnav-label">About Us</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/advertise" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Advertise">
                                                                    <span class="header__subnav-label">Advertise</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/contact-us" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Contact Us">
                                                                    <span class="header__subnav-label">Contact Us</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="https://www.kiiitv.com/kiiijobs" target="_blank" rel="noopener" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Jobs">
                                                                    <span class="header__subnav-label">Jobs</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/meet-the-team" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Meet the Team">
                                                                    <span class="header__subnav-label">Meet the Team</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/tv-listings" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="TV Listings">
                                                                    <span class="header__subnav-label">TV Listings</span>
                                                        </a>
                                                    </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest News Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
            <li class="story-row__item story-row__item_size_half">
                    <tegna-ab uuid="f5cfa64d-055c-468c-9d21-854babd8d35e">
                            <tegna-variant uuid="024afd8e-3387-40f7-ac57-31679284cc2c">
                                <div class="story-row__photo">
                                    <div class="story-row__ratio-enforcer">
                                        <div class="story-row__ratio-enforced">
                                            <a class="story-row__image-link" href="/article/news/investigations/robocalls/stopping-robocalls-investigation/85-2ded57de-8500-4e5a-b540-bddfb4603d1b" aria-label="Read How to stop getting robocalls">
                                                <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="How to stop getting robocalls" width="" height="" src="https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="How to stop getting robocalls" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_360x203.jpg" data-srcset="https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_16x9.jpg 16w, https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_140x79.jpg 140w, https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_360x203.jpg 360w, https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_540x304.jpg 540w, https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_750x422.jpg 750w, https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_1140x641.jpg 1140w, https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /></div>
                                            </a>
                                        </div>
                                    </div>
                                </div>
                                <div class="story-row__text">
                                    <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/news/investigations/robocalls/stopping-robocalls-investigation/85-2ded57de-8500-4e5a-b540-bddfb4603d1b">How to stop getting robocalls</a></h4>
                                                                    </div>
                            </tegna-variant>
                            <tegna-variant uuid="8500589a-a5f5-4144-a3ad-c942d76ebb9d">
                                <div class="story-row__photo">
                                    <div class="story-row__ratio-enforcer">
                                        <div class="story-row__ratio-enforced">
                                            <a class="story-row__image-link" href="/article/news/investigations/robocalls/stopping-robocalls-investigation/85-2ded57de-8500-4e5a-b540-bddfb4603d1b" aria-label="Read What you can do to stop robocalls">
                                                <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="What you can do to stop robocalls" width="" height="" src="https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="What you can do to stop robocalls" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_360x203.jpg" data-srcset="https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_16x9.jpg 16w, https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_140x79.jpg 140w, https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_360x203.jpg 360w, https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_540x304.jpg 540w, https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_750x422.jpg 750w, https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_1140x641.jpg 1140w, https://media.kiiitv.com/assets/WXIA/images/7a1aa2ab-662f-4ac0-ae72-600016239c37/7a1aa2ab-662f-4ac0-ae72-600016239c37_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /></div>
                                            </a>
                                        </div>
                                    </div>
                                </div>
                                <div class="story-row__text">
                                    <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/news/investigations/robocalls/stopping-robocalls-investigation/85-2ded57de-8500-4e5a-b540-bddfb4603d1b">What you can do to stop robocalls</a></h4>
                                                                    </div>
                            </tegna-variant>
                    </tegna-ab>
            </li>
            <li class="story-row__item story-row__item_size_half">
                    <tegna-ab uuid="cc5cd942-dbb0-4d25-986f-5b2bfcfb126a">
                            <tegna-variant uuid="953d3d2e-9fb6-4052-b375-7bbb9ddb5ef9">
                                <div class="story-row__photo">
                                    <div class="story-row__ratio-enforcer">
                                        <div class="story-row__ratio-enforced">
                                            <a class="story-row__image-link" href="/article/news/nation-world/instagram-for-kids-attorneys-general-urge-facebook-to-drop-idea/507-528d1ab2-16f7-41a4-aa8f-ebaa42155861" aria-label="Read 44 attorneys general urge Facebook to drop Instagram for kids idea">
                                                <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="44 attorneys general urge Facebook to drop Instagram for kids idea" width="" height="" src="https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="44 attorneys general urge Facebook to drop Instagram for kids idea" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_360x203.jpg" data-srcset="https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_16x9.jpg 16w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_140x79.jpg 140w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_360x203.jpg 360w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_540x304.jpg 540w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_750x422.jpg 750w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_1920x1080.jpg 1920w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_1140x641.jpg 1140w" sizes="calc(50vw - 15px)" /></div>
                                            </a>
                                        </div>
                                    </div>
                                </div>
                                <div class="story-row__text">
                                    <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/news/nation-world/instagram-for-kids-attorneys-general-urge-facebook-to-drop-idea/507-528d1ab2-16f7-41a4-aa8f-ebaa42155861">44 attorneys general urge Facebook to drop Instagram for kids idea</a></h4>
                                                                    </div>
                            </tegna-variant>
                            <tegna-variant uuid="953105ee-33d1-4f73-bac0-bf8057693a10">
                                <div class="story-row__photo">
                                    <div class="story-row__ratio-enforcer">
                                        <div class="story-row__ratio-enforced">
                                            <a class="story-row__image-link" href="/article/news/nation-world/instagram-for-kids-attorneys-general-urge-facebook-to-drop-idea/507-528d1ab2-16f7-41a4-aa8f-ebaa42155861" aria-label="Read State AGs urge Facebook to cancel plans for Instagram for kids under 13">
                                                <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="State AGs urge Facebook to cancel plans for Instagram for kids under 13" width="" height="" src="https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="State AGs urge Facebook to cancel plans for Instagram for kids under 13" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_360x203.jpg" data-srcset="https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_16x9.jpg 16w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_140x79.jpg 140w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_360x203.jpg 360w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_540x304.jpg 540w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_750x422.jpg 750w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_1920x1080.jpg 1920w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_1140x641.jpg 1140w" sizes="calc(50vw - 15px)" /></div>
                                            </a>
                                        </div>
                                    </div>
                                </div>
                                <div class="story-row__text">
                                    <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/news/nation-world/instagram-for-kids-attorneys-general-urge-facebook-to-drop-idea/507-528d1ab2-16f7-41a4-aa8f-ebaa42155861">State AGs urge Facebook to cancel plans for Instagram for kids under 13</a></h4>
                                                                    </div>
                            </tegna-variant>
                            <tegna-variant uuid="c18d14bc-d821-4fd8-805a-992c32faf3e1">
                                <div class="story-row__photo">
                                    <div class="story-row__ratio-enforcer">
                                        <div class="story-row__ratio-enforced">
                                            <a class="story-row__image-link" href="/article/news/nation-world/instagram-for-kids-attorneys-general-urge-facebook-to-drop-idea/507-528d1ab2-16f7-41a4-aa8f-ebaa42155861" aria-label="Read Facebook idea for Instagram app for younger kids blasted by 44 state AGs">
                                                <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="Facebook idea for Instagram app for younger kids blasted by 44 state AGs" width="" height="" src="https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="Facebook idea for Instagram app for younger kids blasted by 44 state AGs" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_360x203.jpg" data-srcset="https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_16x9.jpg 16w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_140x79.jpg 140w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_360x203.jpg 360w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_540x304.jpg 540w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_750x422.jpg 750w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_1920x1080.jpg 1920w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_1140x641.jpg 1140w" sizes="calc(50vw - 15px)" /></div>
                                            </a>
                                        </div>
                                    </div>
                                </div>
                                <div class="story-row__text">
                                    <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/news/nation-world/instagram-for-kids-attorneys-general-urge-facebook-to-drop-idea/507-528d1ab2-16f7-41a4-aa8f-ebaa42155861">Facebook idea for Instagram app for younger kids blasted by 44 state AGs</a></h4>
                                                                    </div>
                            </tegna-variant>
                            <tegna-variant uuid="d02e92d1-70b0-4704-82dc-e15433d01239">
                                <div class="story-row__photo">
                                    <div class="story-row__ratio-enforcer">
                                        <div class="story-row__ratio-enforced">
                                            <a class="story-row__image-link" href="/article/news/nation-world/instagram-for-kids-attorneys-general-urge-facebook-to-drop-idea/507-528d1ab2-16f7-41a4-aa8f-ebaa42155861" aria-label="Read Facebook&#x27;s Instagram for kids plan should be abandoned, 44 US AGs say">
                                                <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="Facebook's Instagram for kids plan should be abandoned, 44 US AGs say" width="" height="" src="https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="Facebook's Instagram for kids plan should be abandoned, 44 US AGs say" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_360x203.jpg" data-srcset="https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_16x9.jpg 16w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_140x79.jpg 140w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_360x203.jpg 360w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_540x304.jpg 540w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_750x422.jpg 750w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_1920x1080.jpg 1920w, https://media.kiiitv.com/assets/CCT/images/8a28abc4-4d40-4c59-b290-eef02b1f6609/8a28abc4-4d40-4c59-b290-eef02b1f6609_1140x641.jpg 1140w" sizes="calc(50vw - 15px)" /></div>
                                            </a>
                                        </div>
                                    </div>
                                </div>
                                <div class="story-row__text">
                                    <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/news/nation-world/instagram-for-kids-attorneys-general-urge-facebook-to-drop-idea/507-528d1ab2-16f7-41a4-aa8f-ebaa42155861">Facebook&#x27;s Instagram for kids plan should be abandoned, 44 US AGs say</a></h4>
                                                                    </div>
                            </tegna-variant>
                    </tegna-ab>
            </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                                            <li>
                            <div class="header__mini-live-video">
    <div data-module="watch-live" class="watch-live watch-live_active_false" data-watch-enabled="true">
        <a class="watch-live__cta" href="/watch">
            <span class="watch-live__label">Watch</span>
        </a>
        <div class="watch-live__mini-live-video">
            <a class="watch-live__video-link" href="/watch">
    <div data-module="mini-live-video" class="mini-live-video" data-is-watch="false">
        
        <div class="mini-live-video__controls">
        </div>
        <div class="mini-live-video__player"></div>
    </div>            </a>
        </div>
    </div>                            </div>
                        </li>
                                        <li class="header__nav-item header__nav-item_type_search">
                        <span class="header__nav-link header__nav-link_type_search">
                            <label class="header__nav-label header__nav-label_type_search" for="site_search">Search</label>
                        </span>
                        <div class="header__subnav header__subnav_type_search">
                            <div class="header__subnav-group header__subnav-group_name_search">
                                <form class="header__search-form" method="GET" action="/search">
                                    <label class="header__search-label" for="site_search">Search:</label>
                                    <input class="header__search-box" placeholder="Search kiiitv.com" id="site_search" type="search" name="q" />
                                    <button class="header__search-submit" type="submit">Search</button>
                                </form>
                            </div>
                        </div>
                    </li>
                </ul>
                    <div class="header__sponsor">
        <div data-module="ad" class="ad ad_position_masthead_sponsor ad_background_false"
         data-status="new"
         data-path="/32805352/tx-corpuschristi-KIII-B3364_DesktopTablet/masthead_sponsor/news/politics"
         data-sizes="[[112,38]]"
         data-delay="0"
         data-position="masthead_sponsor"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-a9-enabled="true"
         data-index-enabled="false"
         data-index-url="//js-sec.indexww.com/ht/p/184603-10280351191959.js"
         data-targeting-strnativekey=""
         data-collapse="false">
        <div class="ad__inner ad__inner_border_false ad__inner_background_false" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                    </div>
                <a class="header__weather-link" href="/weather" data-tracking-action="weather-summary/weatherClicked" data-tracking-category="link click" data-tracking-label="Link From: https://www.kiiitv.com/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c">
                    <div class="header__weather">
                        <div class="header__weather-desktop-info">
                            <div class="header__weather-label header__weather-label_alerts_false">Right Now</div>
                            <div class="header__weather-city header__weather-city_alerts_false">Corpus Christi, TX&nbsp;&raquo;</div>
                        </div>
                        <div class="header__weather-content">
                            <div class="header__weather-info header__weather-info_alerts_false">
                                <div class="header__weather-temp header__weather-temp_alerts_false">83&deg;</div>

                                <div class="header__weather-icon header__weather-icon_alerts_false">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="" width="26px" height="26px" src="/assets/shared-images/weather-icons/wx-69_8x8.png" /><img class="lazy-image__image lazy-image__image_blur_false" alt="" width="26px" height="26px" src="/assets/shared-images/backgrounds/blank.png" data-src="/assets/shared-images/weather-icons/wx-69_32x32.png" data-srcset="/assets/shared-images/weather-icons/wx-69_8x8.png 8w, /assets/shared-images/weather-icons/wx-69_16x16.png 16w, /assets/shared-images/weather-icons/wx-69_32x32.png 32w, /assets/shared-images/weather-icons/wx-69_64x64.png 64w, /assets/shared-images/weather-icons/wx-69_128x128.png 128w, /assets/shared-images/weather-icons/wx-69_210x210.png 210w" sizes="26px" /><noscript><img class="lazy-image__nojs-image" alt="" width="26px" height="26px" src="/assets/shared-images/weather-icons/wx-69_32x32.png" srcset="/assets/shared-images/weather-icons/wx-69_8x8.png 8w, /assets/shared-images/weather-icons/wx-69_16x16.png 16w, /assets/shared-images/weather-icons/wx-69_32x32.png 32w, /assets/shared-images/weather-icons/wx-69_64x64.png 64w, /assets/shared-images/weather-icons/wx-69_128x128.png 128w, /assets/shared-images/weather-icons/wx-69_210x210.png 210w" sizes="26px" loading="lazy" /></noscript></div>
                                </div>
                            </div>
                            <div class="header__weather-city header__weather-city_alerts_false">Corpus Christi, TX&nbsp;&raquo;</div>
                        </div>
                    </div>
                </a>
            <div class="header__alerts">
                    <a class="header__alert header__alert_type_weather header__alert_visible_false" href="/weather/alerts" data-tracking-action="weatheralert/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: https://www.kiiitv.com/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c">Weather</a>
                                    <a class="header__alert header__alert_type_closings header__alert_visible_false" href="/closings" data-tracking-action="closingsalert/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: https://www.kiiitv.com/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c">Closings</a>
            </div>
            </nav>
        </div>
    </div>
    <div class="header__featured">
            <div class="header__featured-arrow header__featured-arrow_direction_previous"><img src="/images/header/arrow.png" width="14" height="14" loading="eager" alt="" /></div>
            <div class="header__featured-inner">
                <ul class="header__featured-list">
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/hurricane">Hurricane Central</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/coronavirus-covid-19">Coronavirus</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/verify">VERIFY</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/section/domingo-live">Domingo Live!</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/wearehiring">Yes! We&#x2019;re Hiring</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/contests">Contests</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/distinguished-scholars">Distinguished Scholars</a>
                        </li>
                </ul>
            </div>
            <div class="header__featured-arrow header__featured-arrow_direction_next"><img src="/images/header/arrow.png" width="14" height="14" loading="eager" alt="" /></div>
    </div>
</header>            </div>
            <div class="page__dock">
                    <div class="page__breaking-news-alerts">
    <div data-module="breaking-news-alerts" class="breaking-news-alerts breaking-news-alerts_visible_false">
        <div class="breaking-news-alerts__wrap">
            <div class="breaking-news-alerts__close"></div>
            <div class="breaking-news-alerts__label">Breaking News</div>
            <ul class="breaking-news-alerts__headline-wrap">
                <template class="breaking-news-alerts__template">
                    <li class="breaking-news-alerts__item">
                        <a class="breaking-news-alerts__link" href="#" data-tracking="breaking-news-alerts/linkClicked">
                            <span class="breaking-news-alerts__headline"></span>
                            <span class="breaking-news-alerts__read-more">Read More &raquo;</span>
                        </a>
                    </li>
                </template>
            </ul>
            <a class="breaking-news-alerts__more" href="/breaking-news" data-tracking="breaking-news-alerts/moreClicked">More (<span class="breaking-news-alerts__count"></span>) &raquo;</a>
        </div>
    </div>
                    </div>
            </div>
        <main class="page__main" id="main">
            <div class="page__grid">
                


    <div data-module="grid" class="grid grid_version_2-1">
                <div class="grid__section grid__section_theme_default" data-theme="default" style="z-index:1">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_right grid__main_full-width_false">
                            <h1 class="grid__page-heading_visible_false">Corpus Christi&#x27;s Leading Local News: Weather, Traffic, Sports and more | Corpus Christi, Texas | kiiitv.com</h1>
                                                                <div class="grid__cell grid__cell_columns_2" data-columns="2">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_article" data-module-sizer="article" data-count="1">
<article class="article" data-module="article"
         data-article-id="3ec6c658-1b45-4bfa-875b-c78ff659ae8c"
         data-title="Republican former state Sen. Don Huffines launches primary challenge to Gov. Greg Abbott"
         data-seo-title="Former state senator from Dallas will challenge Gov. Abbott"
         data-abstract="Huffines, who has criticized Abbott as being too slow to fully reopen the state, served in the Senate from 2015-2019."
         data-section="news"
         data-subsection="politics"
         data-topic=""
         data-subtopic=""
         data-url="www.kiiitv.com/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c"
         data-gpt-network-code="32805352"
         data-categories="politics, news, home"
         data-author="Patrick Svitek (The Texas Tribune)"
         data-keywords="[&#xD;&#xA;  &quot;politics&quot;,&#xD;&#xA;  &quot;news&quot;,&#xD;&#xA;  &quot;home&quot;&#xD;&#xA;]"
         data-has-video="true"
         data-t1-publisher="Elizabeth Wiley">
    <a class="article__category" href="/section/politics">Politics</a>
    <h1 class="article__headline">Republican former state Sen. Don Huffines launches primary challenge to Gov. Greg Abbott</h1>
    <div class="article__summary">Huffines, who has criticized Abbott as being too slow to fully reopen the state, served in the Senate from 2015-2019.</div>
    <div class="article__lead-asset">
        <div data-module="video" class="video"
             data-stream="https://video.tegna-media.com/assets/WFAA/videos/74acc369-e3cb-46d7-94fc-305b3e0bc538/74acc369-e3cb-46d7-94fc-305b3e0bc538.m3u8"
             data-float="true"
             data-thumbnail="https://media.kiiitv.com/assets/WFAA/images/8382a351-5048-492e-916f-8b9b40ac7ead/8382a351-5048-492e-916f-8b9b40ac7ead_1920x1080.jpg"
             data-title="Former Texas state Sen. Don Huffines announces challenge to Abbott for governor"
             data-description="Huffines will try to oust Gov. Greg Abbott in the Republican primary."
             data-site="287"
             data-id="74acc369-e3cb-46d7-94fc-305b3e0bc538"
             data-dfpposition=""
             data-mute="false"
             data-autoplay="true"
             data-link="https://www.kiiitv.com/video/news/politics/elections/former-texas-state-sen-don-huffines-announces-challenge-to-abbott-for-governor/287-74acc369-e3cb-46d7-94fc-305b3e0bc538"
             data-origin="clipping"
             data-section="news"
             data-subsection="politics"
             data-subcategory="politics"
             data-topic="elections"
             data-subtopic=""
             data-captions=""
             data-related-playlist-id="W4wdI2dr"
             data-related-media-id="w5WFyCfF"
             data-use-trending="true"
             data-is-watch-player="false"
             data-is-live-now="false"
             data-ugc-preroll-disabled="true"
             data-duration="21"
             data-disable-preroll-at-duration="0">
            <div class="video__ratio-enforcer">
                <div class="video__ratio-enforced">
                    <div class="video__inner">
                        <div class="video__teaser video__teaser_visible_true">
                            <img class="video__thumbnail" data-asset-fallback="default" src="https://media.kiiitv.com/assets/WFAA/images/8382a351-5048-492e-916f-8b9b40ac7ead/8382a351-5048-492e-916f-8b9b40ac7ead_1920x1080.jpg" />
                            <div class="video__error"></div>
                            <div class="video__button video__button_play"></div>
                        </div>
                        <div class="video__player-container">
                            <div class="video__player"></div>
                        </div>
                    </div>
                </div>
            </div>
                            <script type="application/ld+json">
                    {
                    "@context": "http://schema.org",
                    "@type": "VideoObject",
                    "name": "Former Texas state Sen. Don Huffines announces challenge to Abbott for governor",
                    "description": "Huffines will try to oust Gov. Greg Abbott in the Republican primary.",
                    "thumbnailUrl": "https://media.kiiitv.com/assets/WFAA/images/8382a351-5048-492e-916f-8b9b40ac7ead/8382a351-5048-492e-916f-8b9b40ac7ead_1920x1080.jpg",
                    "uploadDate": "",
                    "duration": "21",
                    "contentUrl": "https://www.kiiitv.com/video/news/politics/elections/former-texas-state-sen-don-huffines-announces-challenge-to-abbott-for-governor/287-74acc369-e3cb-46d7-94fc-305b3e0bc538",
                    "embedUrl": "https://media.kiiitv.com/embeds/video/74acc369-e3cb-46d7-94fc-305b3e0bc538/iframe"
                    }
                </script>
        </div>
    </div>
    <aside class="article__meta">
            <div class="article__author">
                <span class="article__meta-label">Author:</span> Patrick Svitek (The Texas Tribune)
            </div>
                    <div class="article__published">
                <span class="article__meta-label">Published:</span> 10:11 AM CDT May 10, 2021
            </div>
                    <div class="article__updated">
                <span class="article__meta-label">Updated:</span> 10:11 AM CDT May 10, 2021
            </div>
            <div data-module="article-sharing" class="article-sharing">
        <a class="article-sharing__icon" href="https://www.facebook.com/dialog/share?app_id=925032594320493&display=popup&href=https://www.kiiitv.com/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c&redirect_uri=https://www.kiiitv.com/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c" target="_blank" data-tracking-action="sharing/facebookLink" data-tracking-category="link click" data-tracking-label="Link From: https://www.kiiitv.com/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c">
            <img class="article-sharing__logo" alt="Facebook" src="/assets/shared-images/icons/facebook.svg" loading="eager" width="38" onload="this.parentElement.style.opacity='1';" />
        </a>
        <a class="article-sharing__icon" href="https://twitter.com/intent/tweet?text=Republican%20former%20state%20Sen.%20Don%20Huffines%20launches%20primary%20challenge%20to%20Gov.%20Greg%20Abbott&url=https://www.kiiitv.com/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c&via=kiii3news" target="_blank" data-tracking-action="sharing/twitterLink" data-tracking-category="link click" data-tracking-label="Link From: https://www.kiiitv.com/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c">
            <img class="article-sharing__logo" alt="Twitter" src="/assets/shared-images/icons/twitter.svg" loading="eager" width="38" onload="this.parentElement.style.opacity='1';" />
        </a>
    </div>    </aside>
    <div class="article__body">
                            <div class="article__section article__section_type_text utility__text">
<p>DALLAS — <a href="https://www.texastribune.org/2021/05/10/don-huffines-texas-greg-abbott/" rel="noopener noreferrer" target="_blank"><em><strong>This story originally appeared</strong></em></a><em><strong>&nbsp;</strong></em><em><strong>in The Texas Tribune.</strong></em></p>                                            </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Former state Sen. Don Huffines, a conservative Republican from Dallas who has been critical of Gov. <a href="https://www.texastribune.org/directory/greg-abbott/">Greg Abbott</a>'s coronavirus policies, announced Monday that he is challenging Abbott in the 2022 primary.</p>                                            </div>
                    <div class="article__section article__section_type_text utility__text">
<p>"Texas deserves actual Republican leadership that will act urgently and decisively—no more excuses or lies," Huffines said in a statement, vowing bolder action on border security, property taxes and elections.</p>                                            </div>
                        <div class="article__section article__section_type_ad">
        <div data-module="ad" class="ad ad_position_article_mid1 ad_background_true"
         data-status="new"
         data-path="/32805352/tx-corpuschristi-KIII-B3364_DesktopTablet/article_mid1/news/politics"
         data-sizes="[[300,250],[1,1],[750,570],[1,2]]"
         data-delay="8"
         data-position="article_mid1"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-a9-enabled="true"
         data-index-enabled="false"
         data-index-url="//js-sec.indexww.com/ht/p/184603-10280351191959.js"
         data-targeting-strnativekey=""
         data-collapse="false">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                        </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Huffines is a wealthy businessman who served in the Senate from 2015-2019. He was unseated by Democrat Nathan Johnson in 2018.</p>                                            </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Abbott is up for a third term in 2022 and has drawn some heat from within his party for his response to the coronavirus pandemic. Huffines has criticized Abbott as being too slow to fully reopen the state and he spoke at a protest outside the Governor's Mansion last fall.</p>                                            </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Huffines' announcement did not mention Abbott but took aim at "politicians who offer nothing but excuses and lies" and promised to take on the "entrenched elites of the Austin swamp." In promising more decisive action, Huffines said Texas needs to "finally finish the [border] wall" and that he would put the state "on a path to eliminating property taxes."</p>                                            </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Huffines may not be the only credible Abbott challenger in the March 1 primary, which could get rescheduled due to the redistricting process. Other potential opponents include Allen West, chairman of the Texas GOP, and Agriculture Commissioner Sid Miller. The filing deadline for the currently scheduled primary is Dec. 13.</p>                                            </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Abbott's campaign did not immediately respond to a request for comment on Huffines' candidacy.</p>                                            </div>
                                <div class="article__section article__section_type_embed">
                                    <blockquote class="twitter-tweet"><p lang="en" dir="ltr">Together we will finish the wall, lower our taxes, and protect our elections. <br><br>It’s past time to root out corruption in the Austin swamp.<br><br>Leadership. No excuses. (An Actual Republican)<br><br>Join me &gt;&gt;&gt; <a href="https://t.co/DZMUW33iIh">https://t.co/DZMUW33iIh</a> <a href="https://t.co/dS0we5MGi4">pic.twitter.com/dS0we5MGi4</a></p>&mdash; Don Huffines (@DonHuffines) <a href="https://twitter.com/DonHuffines/status/1391757604645490689?ref_src=twsrc%5Etfw">May 10, 2021</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Huffines was a strident conservative in the Senate. His announcement highlighted his record on issues important to the right, as well as his successful push to shut down the Dallas Public Schools bus agency amid reports of financial mismanagement there.</p>                                            </div>
                    <div class="article__section article__section_type_text utility__text">
<p>He got to the Senate in 2015 after unseating Sen. John Carona, R-Dallas, in the primary, attacking him as too moderate. But the Dallas-based Senate District 16 swung toward Democrats under former President Donald Trump, and Johnson beat Huffines by 8 percentage points in 2018.</p>                                            </div>
                                <div class="article__section article__section_type_ad">
        <div data-module="ad" class="ad ad_position_article_mid2 ad_background_true"
         data-status="new"
         data-path="/32805352/tx-corpuschristi-KIII-B3364_DesktopTablet/article_mid2/news/politics"
         data-sizes="[[300,250],[1,1]]"
         data-delay="8"
         data-position="article_mid2"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-a9-enabled="true"
         data-index-enabled="false"
         data-index-url="//js-sec.indexww.com/ht/p/184603-10280351191959.js"
         data-targeting-strnativekey="[&#xD;&#xA;  &quot;2YNEkKMk1QC5WsCndTXLDYVB&quot;&#xD;&#xA;]"
         data-collapse="false">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Huffines stayed politically active after leaving the Senate and especially so in the past year, as conservative angst simmered over Abbott's pandemic management. Even then, Huffines has an interesting family connection to the governor's circle: His brother is James Huffines, who Abbott tapped last spring to chair the Governor’s Strike Force to Open Texas.</p>                                            </div>
                    <div class="article__section article__section_type_text utility__text">
<p><a href="https://www.texastribune.org/"><em>The Texas Tribune</em></a><em>&nbsp;is a nonpartisan, nonprofit media organization that informs Texans — and engages with them – about public policy, politics, government and statewide issues.</em></p>                                            </div>
                                <div class="article__section article__section_type_embed">
                                    <iframe class="embedly-embed" src="//cdn.embedly.com/widgets/media.html?src=https%3A%2F%2Fwww.youtube.com%2Fembed%2Fy5AtEfbnpss&display_name=YouTube&url=https%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3Dy5AtEfbnpss&image=http%3A%2F%2Fi.ytimg.com%2Fvi%2Fy5AtEfbnpss%2Fhqdefault.jpg&key=0350728de3d54ab7950f978fc80d4a70&type=text%2Fhtml&schema=youtube" width="548" height="308" scrolling="no" title="YouTube embed" frameborder="0" allow="autoplay; fullscreen" allowfullscreen="true"></iframe>
                                </div>

<div data-module="related-stories" class="related-stories">
    <h2 class="related-stories__heading">Related Articles</h2>
    <ul class="related-stories__stories">
            <li class="related-stories__story">
                <a class="related-stories__link" href="http://www.kiiitv.com/article/news/politics/inside-politics/texas-politics/will-texas-democrats-field-a-viable-candidate-for-governor-next-year/287-75a4a1f8-8179-4aaa-9e64-0a78f2a42ff0" data-tracking-action="related-article/linkClicked" data-tracking-category="link click" data-tracking-label="Will Texas Democrats field a viable candidate for governor next year?">Will Texas Democrats field a viable candidate for governor next year?</a>
            </li>
            <li class="related-stories__story">
                <a class="related-stories__link" href="http://www.kiiitv.com/article/news/local/texas/matthew-mcconaughey-texas-governor-political-past/285-4381f292-b1c4-472f-9300-93b5f75d028c" data-tracking-action="related-article/linkClicked" data-tracking-category="link click" data-tracking-label="Matthew McConaughey is flirting with a run for governor. But his politics remain a mystery.">Matthew McConaughey is flirting with a run for governor. But his politics remain a mystery.</a>
            </li>
            <li class="related-stories__story">
                <a class="related-stories__link" href="http://www.kiiitv.com/article/news/politics/beto-orourke-texas-governor-run-2022/269-c4d951d6-9673-4851-99ce-6e1a656cb6cd" data-tracking-action="related-article/linkClicked" data-tracking-category="link click" data-tracking-label="Beto O&#x27;Rourke weighing run for Texas governor in 2022">Beto O&#x27;Rourke weighing run for Texas governor in 2022</a>
            </li>
    </ul>
</div>    </div>
    <script type="application/ld+json">
        {
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "headline": "Republican former state Sen. Don Huffines launches primary challenge to Gov. Greg Abbott",
  "datePublished": "10:11 AM CDT May 10, 2021",
  "dateModified": "10:11 AM CDT May 10, 2021",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.kiiitv.com/article/news/politics/republican-former-state-sen-don-huffines-primary-challenge-gov-greg-abbott/287-3ec6c658-1b45-4bfa-875b-c78ff659ae8c"
  },
  "author": {
    "@type": "Person",
    "name": "Patrick Svitek (The Texas Tribune)"
  },
  "publisher": {
    "@type": "Organization",
    "name": "KIII",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.kiiitv.com/assets/shared-images/amp-logos/kiii.png",
      "width": 340,
      "height": 60
    }
  }
}
    </script>
</article>                                    </div>
                                </div>
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_taboola" data-module-sizer="taboola" data-count="1">
    <div data-module="taboola" class="taboola" id="taboola-below-article-thumbnails-2nd-::articleNumber::"
         data-page-type="article"
         data-ad="below_taboola"
         data-mode="thumbnails-h2"
         data-target-type="mix"
         data-placement="Below Article Thumbnails 2nd"
         data-url="http://www.kiiitv.com::contentUrl::">
    </div>
                                    </div>
                                </div>
                        </div>
                </div>

                    <div class="grid__sticky-column grid__sticky-column_side_right">
                        <div class="grid__sticky-content" data-columns="1">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_ad" data-module-sizer="ad" data-count="1">
        <div data-module="ad" class="ad ad_position_article_atf ad_background_true"
         data-status="new"
         data-path="/32805352/tx-corpuschristi-KIII-B3364_DesktopTablet/article_atf/news/politics"
         data-sizes="[[300,250],[300,600]]"
         data-delay="8"
         data-position="article_atf"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-a9-enabled="true"
         data-index-enabled="false"
         data-index-url="//js-sec.indexww.com/ht/p/184603-10280351191959.js"
         data-targeting-strnativekey=""
         data-collapse="false">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 250px; min-width: 300px;">
                    <noscript>
                        <iframe src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/32805352/tx-corpuschristi-KIII-B3364_DesktopTablet/article_atf/news/politics&amp;sz=300x250|300x600&amp;c=192" width="300" height="600" frameborder="0"></iframe>
                    </noscript>
        </div>
    </div>
                                    </div>
                                </div>
                        </div>
                    </div>
            </div>
        </div>
        <div class="grid__section grid__section_theme_default" data-theme="default" style="z-index:0">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_none grid__main_full-width_false">
                                                                <div class="grid__cell grid__cell_columns_3" data-columns="3">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_ad" data-module-sizer="ad" data-count="1">
        <div data-module="ad" class="ad ad_position_article_flex_btf ad_background_true"
         data-status="new"
         data-path="/32805352/tx-corpuschristi-KIII-B3364_DesktopTablet/article_flex_btf/news/politics"
         data-sizes="[[970,250],[728,90],[1140,286],[1,1]]"
         data-delay="8"
         data-position="article_flex_btf"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-a9-enabled="true"
         data-index-enabled="false"
         data-index-url="//js-sec.indexww.com/ht/p/184603-10280351191959.js"
         data-targeting-strnativekey=""
         data-collapse="false">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
                    <noscript>
                        <iframe src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/32805352/tx-corpuschristi-KIII-B3364_DesktopTablet/article_flex_btf/news/politics&amp;sz=970x250|728x90|1140x286|1x1&amp;c=192" width="1140" height="286" frameborder="0"></iframe>
                    </noscript>
        </div>
    </div>
                                    </div>
                                </div>
                        </div>
                </div>

            </div>
        </div>
        <div class="grid__section grid__section_theme_default" data-theme="default" style="z-index:0">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_none grid__main_full-width_false">
                                                                <div class="grid__cell grid__cell_columns_3" data-columns="3">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_article-loader" data-module-sizer="article-loader" data-count="1">

<div class="article-loader" data-module="article-loader">
    <button class="article-loader__button"></button>
</div>                                    </div>
                                </div>
                        </div>
                </div>

            </div>
        </div>
    </div>

            </div>
        </main>
            <div class="page__footer page__footer_theme_default">
<footer data-module="footer" class="footer">
    <div class="footer__outer">
        <div class="footer__inner">
            <div class="footer__logo-wrap">
                <img class="footer__logo" alt="KIII-TV" src="/assets/shared-images/logos/kiii.png">
            </div>
            <div class="footer__menu">
                    <ul class="footer__list">
                                <li class="footer__item"><a class="footer__link" href="https://www.kiiitv.com/kiiijobs" target="_blank" rel="noopener">Jobs</a></li>
                                <li class="footer__item"><a class="footer__link" href="/terms" target="_self" rel="">Terms of Service</a></li>
                                <li class="footer__item"><a class="footer__link" href="/privacy" target="_self" rel="">Privacy Policy</a></li>
                                <li class="footer__item"><a class="footer__link" href="/adchoices" target="_self" rel="">Ad Choices</a></li>
                    </ul>
                    <ul class="footer__list">
                                <li class="footer__item"><a class="footer__link" href="https://interactive.kiiitv.com/pdfs/PublicFileReport.pdf" target="_blank" rel="noopener">EEO Public File Report</a></li>
                                <li class="footer__item"><a class="footer__link" href="/fcc-public-inspection-file" target="_self" rel="">FCC Online Public Inspection File</a></li>
                                <li class="footer__item"><a class="footer__link" href="/closed-captioning" target="_self" rel="">Closed Caption Procedures</a></li>
                                <li class="footer__item footer__item_visible_false"><a class="footer__link footer__link_behavior_show-consent-options" target="_self" href="/do-not-sell-my-information">Do Not Sell My Personal Information</a></li>
                    </ul>
            </div>
            <div class="footer__copyright">
                &copy; 2021 KIII-TV. All Rights Reserved.
            </div>
        </div>
    </div>
</footer>            </div>
    </div>
        <div class="page__interstitial">
        <div data-module="ad" class="ad ad_position_exit_interstitial ad_background_true"
         data-status="new"
         data-path="/32805352/tx-corpuschristi-KIII-B3364_DesktopTablet/exit_interstitial/news/politics"
         data-sizes="[[1,1]]"
         data-delay="8"
         data-position="exit_interstitial"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-a9-enabled="true"
         data-index-enabled="false"
         data-index-url="//js-sec.indexww.com/ht/p/184603-10280351191959.js"
         data-targeting-strnativekey=""
         data-collapse="false">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
        </div>
            <div class="page__notifications">

<div data-module="notifications" class="notifications" style="display:none">
    <div class="notifications__logo-container">
        <img class="notifications__logo" alt="KIII" src="/assets/shared-images/logos/kiii.png" />
    </div>
    <h2 class="notifications__heading">KIII would like to send you push notifications about the latest news and weather.</h2>
    <p class="notifications__description">Notifications can be turned off anytime in the browser settings.</p>
    <div class="notifications__buttons">
        <button class="notifications__button notifications__button_option_no notifications__button_default_false">No Thanks</button>
        <button class="notifications__button notifications__button_option_yes notifications__button_default_true">Allow</button>
    </div>
</div>
        </div>
        <div class="page__toasts">

<div class="toasts">
    <script class="toasts__toast-template" type="text/template">
        <div class="toasts__toast toasts__toast_new_true">
            <div class="toasts__logo-container">
                <img class="toasts__logo" src="/assets/shared-images/logos/kiii.png" />
            </div>
            <div class="toasts__close">×</div>
            <div class="toasts__content">
                <div class="toasts__title"></div>
                <div class="toasts__body"></div>
                <p class="toasts__link">Read More</p>
            </div>
        </div>
    </script>
</div>        </div>
    <div class="modal modal_open_false" data-theme="modal">
    <button class="modal__close-button" aria-label="close"></button>
    <div class="modal__content"></div>
</div>    <script data-key="pNHOjJyj2m9zXrCu&#x2B;E8emJVKczLfYeNWPKDJjw==">window.jwplayer=window.jwplayer||{},window.jwplayer.key=window.jwplayer.key||document.currentScript.dataset.key;
//# sourceMappingURL=jwplayer-key.js.map</script>
    <script>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</script>
    <script data-base="/" data-modules="ad,adchoices,all-alerts,app-badge,app-promo-link,article,article-loader,article-sharing,article-verify-claim,breaking-news-alerts,breaking-news-list,carousel,chapter-slider,closings,countdown,datasphere,datasphere-ad-article,datasphere-ad-front,election-single-race,elections,error,footer,gallery,grid,header,headline-list,hot-races,hot-races-carousel,hourly-graph,iframe,lazy-image,live-broadcasts,live-video-banner,longform,mini-live-video,modal,near-me,newsletter-signup,notifications,olympics-medal-count,page,personal-info,photo,pollen,privacy,radar-gallery,raw-html,related-stories,right-now-hourly,right-now-radar,search,story,story-list,story-row,taboola,toasts,tos,ugc-cta,universal-ad,video,watch-live,watch-secondary-content,weather-10-day,weather-alerts-list,weather-front-link,weather-hourly,weather-interactive-radar,weather-maps,weather-nav" data-version="5.5.1">!function(){if(window.tegna.supportsJavascript){var e=document.currentScript.dataset.modules.split(","),s=["page","photo","lazy-image","ad","gallery","video","taboola","related-stories","raw-html","elections","election-single-race"];function a(e,s){for(var a=s.length,r=0;r<a;r++)if(s[r]===e)return!0;return!1}for(var r=document.querySelectorAll("[data-module]"),t=0;t<r.length;++t)void 0,a(o=r[t].getAttribute("data-module"),s)||s.push(o);var i=document.currentScript.dataset.version,l=document.currentScript.dataset.base,n=document.getElementsByClassName("page")[0]?document.getElementsByClassName("page")[0].dataset.tealiumUrl:"";const c={utils:"tegna-utils",storage:"tegna-storage",common:"common.min_"+i,swiper:"assets/js-libs/swiper/swiper.min","live-messages":"assets/js-libs/live-messages/live-messages",luxon:"assets/js-libs/luxon/luxon.min",tealium:n,signalr:"assets/js-libs/signalr/signalr.min",jwplayer:"assets/js-libs/jwplayer/jwplayer",comscore:"assets/js-libs/comscore/comscore.min",places:"//maps.googleapis.com/maps/api/js?key=AIzaSyBEGr3U4E-OGcjwkhiXfqxfuvOqDQ7Z96c&libraries=places","@firebase/app":"firebase-app","@firebase/messaging":"firebase-messaging"};e.forEach(e=>{e in c==!1&&(c[e]=`${e}_${i}`)}),require.config({baseUrl:l,waitSeconds:30,bundles:{common:["page","universal-ad","header","footer","grid","breaking-news-alerts","tegna-utils","tegna-storage","tegna-tracking","header-updater"]},paths:c,shim:{swiper:{exports:"Swiper"},signalr:{exports:"signalR"},tealium:["jquery"],jwplayer:["jquery"]}}),s.forEach(e=>{try{require([e])}catch(s){void 0}})}var o}();
//# sourceMappingURL=configure-require.js.map</script>
        <script data-api-key="AIzaSyC54BBAYDxZz1PVRdabPTpBxJJEPXQTtHo" data-project-id="kiii-news-app" data-sender-id="132918417442" data-app-id="1:132918417442:web:8407ac1a23fd5bb6">!function(){if(window.tegna.supportsJavascript){var e=document.currentScript.dataset,a=e.apiKey,i=e.projectId,p=e.senderId,t=e.appid;require(["@firebase/app","@firebase/messaging"],function(e){e.initializeApp({apiKey:a,authDomain:`${i}.firebaseapp.com`,databaseURL:`https://${i}.firebaseio.com`,projectId:i,storageBucket:`${i}.appspot.com`,messagingSenderId:p,appId:t}),window.firebase=e})}}();
//# sourceMappingURL=firebase.js.map</script>
    <script>!function(){if(!window.tegna.supportsJavascript){var e=document.body,t=document.createElement("div");function n(){void 0;for(var e,t,n=document.getElementsByTagName("noscript"),o=0;o<n.length;o++){var r=n.item(o);r.outerHTML=(e=r.innerHTML,t=void 0,(t=document.createElement("textarea")).innerHTML=e,0===t.childNodes.length?"":t.childNodes[0].nodeValue)}}t.innerHTML='<div style="background-color:#c50000;font-family:sans-serif;color:#ffffff;text-align:center;"><h2 style="margin:0;padding:10px 0;">Your browser is not fully supported.</h2><p style="margin:0;padding: 10px 0;">For full feature support, please upgrade to a modern browser such as <a href="https://www.microsoft.com/en-us/edge" style="color:#ffffff;" target="_blank">Microsoft Edge</a>.</p></div>',e.insertBefore(t,e.firstChild),n();var o=window.setInterval(function(){document.getElementsByTagName("noscript").length?n():clearInterval(o)},500)}}();
//# sourceMappingURL=old-browser.js.map</script>
    <script>tegna.performance.parsed = { time: performance.now() };</script>
        <script>
            if (window.tegna.supportsJavascript) {
                window.performance.mark('tegna_requesting_gpt');
                var script = document.createElement('script');
                script.src = "https://www.googletagservices.com/tag/js/gpt.js";
                script.async = true;
                script.defer = true;
                var firstScriptTag = document.getElementsByTagName('script')[0];
                firstScriptTag.parentNode.insertBefore(script, firstScriptTag);
            } else {
                var script = document.createElement('script');
                script.src = "https://www.googletagmanager.com/gtag/js?id=UA-80328443-1";
                var firstScriptTag = document.getElementsByTagName('script')[0];
                firstScriptTag.parentNode.insertBefore(script, firstScriptTag);

                window.dataLayer = window.dataLayer || [];
                function gtag(){dataLayer.push(arguments);}
                gtag('js', new Date());
                gtag('config', 'UA-80328443-1');
            }
        </script>
            <script type="text/javascript" src="//native.sharethrough.com/assets/sfp.js" async></script>
        <script>window.performance.mark('tegna_dom_parsed');</script>
</body>
</html>
